NFSMW - English.bin edits not working

Jan. 20, 2018, 4:48 a.m.
Hello everyone. I'm back from the dead, in case anyone still recognizes me.

ANYWAY… on to the real reason I'm posting.

I did a fresh install of NFSMW on my laptop in order to clear lag issues and freezes and to do a fresh start, as I just literally did a copy+paste from my copy on the PC a long time ago (which included a BUNCH of mods).

Now here's the thing: I downloaded the game from an Internet source, as I no longer have the CD and this laptop doesn't have a CD drive in the first place. It installed fine, but modded language files (such as English.bin, located at LANGUAGES folder) doesn't work anymore. In fact, even if I delete it, the game runs fine, doesn't crash, and seems to pull all the text from the executable itself. How do I set it so that the game pulls the in-game text from the actual language files and not from the executable?

Even with my years of experience, this gets my head scratching. Thanks in advance to whoever replies.
Jan. 20, 2018, 5:31 a.m.
Lol, you have my issue too. I myself don't know exactly, but using one of below tools can do so:
1-Mod Loader (Because MW of my brother's Laptop lacks mod loader and supports edited English.bin so fine.
2-NFSMW Control Panel v1.06
Jan. 20, 2018, 5:45 a.m.
1) I already installed ModLoader, but it doesn't do anything. Although, my installation for this one only involved moving the ADDONS folder, modloader.ini and modloader.dll to the main folder. I'll try installing it through the actual installer.
2) Doesn't do anything, besides enabling/disabling intro movies.
Jan. 20, 2018, 9:16 a.m.
You can install ATTRIBUTES.MWPS files of cars with NFS-VltEd. Don't forget to create a backup from car you want to replace it.
Jan. 20, 2018, 9:45 a.m.
My issue isn't really with the vehicle names - modded cars' names display correctly. My only gripe is with the original cars' names as well as some other text strings I edited to my preference.
For example: in-game, the Fiat Punto's name is simply displayed as "Fiat Punto." I'd prefer it to display as "Fiat Grande Punto Sport." No matter how many times I change it in the English.bin file, the game will still display it as "Fiat Punto."
I have done a LOT of Registry Editing and what it has only done is to allow me to do a fresh install of ModLoader (as I uninstalled it then got into an error while reinstalling it). The files also don't seem to be contained in the executable - I've done a thorough search using a hex editor and there's none to be found. The only thing I'm gonna do now is to actually scour my entire PC to look for the file it's pulling.
Jan. 20, 2018, 1:18 p.m.
Registry?! Dude, there is NFS-LangEd v0.5.0 for it. Download from http://nfs-tools.blogspot.com
Jan. 20, 2018, 9:57 p.m.
You don't really understand…

I know the programs, I know how to mod, and I'm definitely not a newbie. I've been using NFS-LangEd for Most Wanted and Underground 2 for awhile now. My main problem here is the fact that the edits I'm doing to the Most Wanted language files are not appearing in-game - custom car names, racer names, and HUD - well after I did the reinstallation from a different source.

Let me backtrack again so you could see the whole spread of the problem:

In my PC, I have a copy of NFSMW installed from a game disc I bought. I modded it extensively, from cars to textures and even text and new lighting effects. A couple years later, I was given a laptop, and I wanted to install some games on it to keep me entertained. I simply dragged and dropped my copy of Most Wanted from my PC to a flash drive and to the laptop, as I've lost the disc itself (it has been 5 years) and the laptop doesn't have an disc drive in the first place.

I went through it with no issues, but then, things started to glitch out - Blacklist events not appearing, textures missing, framerate issues, and a whole more. I tried 'unmodding' the game (removing all mods except for texture mods and text where I have no backups of), but the issues persisted. I uninstalled the game (by deleting the folder, as it's a copy paste) and, since my PC's dead as of now, I obtained a copy from an Internet source and installed from there.

The game ran fine and I started to mod only the little things (some lighting and texture mods), but when I got to the text modding, my changes do not show up. I tried changing the car names (i.e. from "Fiat Punto" to "Fiat Grande Punto Sport"), but they won't appear. I test it by simply launching the game and looking for a Punto I made in the My Cars menu - it doesn't show up. I double and triple-checked my English.bin file in the LANGUAGES folder, and the changes ARE there - it isn't just showing up in the game. I even went as far as changing "Downtown Rockport" to "Fartcan Diddy" in the files, but it isn't showing up when I go to Career freeroam.

I went as far as DELETING the English.bin file, where the game would probably go nuts and crash on launch, but no, it still runs like normal, displaying text as it should.

It made me think that it HAS to be pulling the file from SOMEWHERE - the executable doesn't contain the text of the game (just a search of "IS300" on the Hex Editor gave an invalid result). I searched the entirety of my laptop and there's no other "English.bin" file hiding in the drives, other than the file of Underground 2 and some backups. Did some registry edits and the only thing it did was to validate the install of the game. Tried your suggestion of NFS Control Panel, but changing the language option from there, as I've said, only enables/disables the intro movies.

Now, do you see the problem?
Jan. 21, 2018, 12:28 a.m.
Yes, I see. That's really weird. Sorry, I don't know how to solve.
Jan. 21, 2018, 9:15 p.m.
can anyone do the video of how to install ATTRIBUTES.MWPS files of cars with NFS-VltEd?

i really want to try since NFS-VLTed 4.5 doesn't support modloader.

Search Forums

Notifications

You currently have no notifications.

{[{ notification.title }]}

{[{ notification.created|timeAgo:'MM/dd/yyyy' }]}
{[{ notification.sender.display_name }]}
older notifications mark all as read
Shoutbox
{[{ shout.created|timeAgo:'MM/dd/yyyy' }]}