Go Back   NFSCars Forums > NFS Forums > General NFS Discussion (1994-2006) > NFS: Hot Pursuit 2

NFS: Hot Pursuit 2 General Discussion of Need For Speed Hot Pursuit 2 (NFS6)

Reply
 
Thread Tools Display Modes
Old 01-28-2011   #1
Anathlyst
Viper Fanatic
 
Anathlyst's Avatar
 
Join Date: Dec 2010
Location: Frankfurt Germany
Posts: 161
Default Windows 7 64 bit problem

Sorry If I put this in the wrong place, but when I tried to Install Need for Speed Hot Pursuit 2 on a Windows 7 64 bit Home Premium, it seemed to install perfectly fine, but whenever I run the game, the screen goes black and then goes back to the desktop. the game shows up as an open window, but whenever I click on it again, it does the same thing, goes black, and then back to the desktop, and I have to use task manager to close it. I've tried running it in compatibility mode, uninstalling it and reinstalling it in compatibility mode, doing it as administrator, nothing changed. Then, when I tried to run Need for Speed ProStreet, which I had installed a long time ago and ran perfectly, it did the exact same thing, even after uninstalling Hot Pursuit 2. I've looked online but no one else seems to have the same problem as me. High Stakes still worked fine, but I have no idea what's wrong.
Anathlyst is offline   Reply With Quote
Old 01-28-2011   #2
UCN Conversions
Semi-Retired..
 
UCN Conversions's Avatar
 
Join Date: Nov 2004
Location: Windsor, VT, USA
Posts: 1,284
Send a message via ICQ to UCN Conversions Send a message via MSN to UCN Conversions Send a message via Skype™ to UCN Conversions
Default

Quote:
Originally Posted by Anathlyst View Post
Sorry If I put this in the wrong place, but when I tried to Install Need for Speed Hot Pursuit 2 on a Windows 7 64 bit Home Premium, it seemed to install perfectly fine, but whenever I run the game, the screen goes black and then goes back to the desktop. the game shows up as an open window, but whenever I click on it again, it does the same thing, goes black, and then back to the desktop, and I have to use task manager to close it. I've tried running it in compatibility mode, uninstalling it and reinstalling it in compatibility mode, doing it as administrator, nothing changed. Then, when I tried to run Need for Speed ProStreet, which I had installed a long time ago and ran perfectly, it did the exact same thing, even after uninstalling Hot Pursuit 2. I've looked online but no one else seems to have the same problem as me. High Stakes still worked fine, but I have no idea what's wrong.
i have Win7 64 bit as well. i had the same problem. then i updated my graphics card driver, and made sure i run the nfshp2.exe as an administrator. now it runs great!

note: i also use the v240 no cd patch, along with copying the entire CD to the nfshp2 root directory., which on win7 64-bit is by default: C: \Program Files (x86)\EA Games\Need For Speed Hot Pursuit 2

Last edited by UCN Conversions; 01-28-2011 at 08:15 PM..
UCN Conversions is offline   Reply With Quote
Old 01-28-2011   #3
Anathlyst
Viper Fanatic
 
Anathlyst's Avatar
 
Join Date: Dec 2010
Location: Frankfurt Germany
Posts: 161
Default

I wasn't able to update my drivers, but going in and setting the setup and game exe files to administrator fixed everything! Thank you so much!

*edit- After the first mod I downloaded, it stopped working and did the same thing, but after copying all the files from the CD and using the no-cd crack, it worked! Thanks once again!

Last edited by Anathlyst; 02-05-2011 at 12:23 PM..
Anathlyst is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -6. The time now is 08:58 AM.



Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.